Unable to log into the Elucidat app

Incident Report for Elucidat

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 13:25 BST

Monitoring

A fix has been deployed, and we are monitoring the results. You can now resume using the app.
Posted Apr 08, 2026 - 12:39 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 08, 2026 - 12:35 BST

Investigating

We are aware of an issue with logging into the app, and we are looking into this right now. Please stand by for updates.
Posted Apr 08, 2026 - 12:15 BST
This incident affected: Authoring.